Back
Resolved

Intermittent Publishing Failures on X (Twitter)

Started 3 Jul at 02:06pm PKT, resolved 7 Jul at 04:47pm PKT.

Web Application (publish.socialchamp.io) Mobile Application (Android & iOS)
Resolved

Update: Our team has successfully rolled out platform add-ons to address the recent X (Twitter) API infrastructure changes.

Due to X's new metered, per-post billing model, posts containing external links now require additional API resources. As a result, link posts are supported through our newly launched X Link Posting add-ons.

If you need to publish posts with links on X, you can now purchase the appropriate add-on from your account and resume posting without interruption. Plain-text posts continue to publish successfully and are not affected by this change.

Thank you for your patience and understanding as we worked through these platform changes. If you have any questions about the available add-ons or need help choosing the right option, our support team is here to help.

Posted 7 Jul at 04:47pm PKT.
Updated

Update: Our team has isolated the specific impact of the recent X (Twitter) API infrastructure changes.

The platform's new metered, per-post billing structure places a significantly higher premium on updates that include external links. As a result, only posts containing links are currently failing. Plain-text posts are completely unaffected and will continue to publish successfully.

We are moving as quickly as possible to deploy specialized platform add-ons to accommodate these new requirements sustainably. Thank you for your continued patience, and we will share more updates as they become available.

Posted 3 Jul at 05:53pm PKT.
Created

We are currently experiencing an active disruption affecting scheduled and direct publishing to X (Twitter).

X has recently implemented an unannounced and significant change to its external API infrastructure. They have transitioned away from a predictable flat monthly rate to a metered, per-post billing structure. Because this unexpected change fundamentally alters how data is transferred, our engineering and product teams are actively working on structuring dedicated add-on options to sustainably accommodate X's new model.

Until these adjustments are deployed, posts scheduled to X may continue to fail. Please note that all other connected networks (Facebook, Instagram, LinkedIn, etc.) are completely unaffected and fully operational.

We sincerely apologize for the inconvenience caused by this external platform shift and will provide updates here as our team implements a permanent fix.

Posted 3 Jul at 02:06pm PKT.